Azure Connectivity DisruptionsOperational

Components

Cloud Services

Locations

Azure



May 7, 2025 3:58PM UTC
[Resolved] Following continued monitoring, Skillable Engineers have confirmed that the mitigation efforts were successful. The issue has now been fully resolved.

May 6, 2025 4:14PM UTC
[Monitoring] Skillable has implemented a rollback to address a recent issue affecting lab launches. Initial observations indicate successful recovery, and our team continues to monitor system performance to ensure stability. While most services have returned to normal, we are conducting further validation to confirm full resolution. We appreciate your patience and will provide updates as needed.

May 6, 2025 2:48PM UTC
[Investigating] Skillable is currently investigating reports of intermittent connectivity issues affecting a subset of users related to Azure Virt Deployments. Our engineering teams are actively working to identify the root cause and restore full functionality as soon as possible. Further information will be shared as it becomes available.

Back to current status